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Introduction 
 

RM Easiteach Database combines powerful professional features with simple tools that 
make managing and analyzing records an engaging activity. 

 
 

What is RM Easiteach Database? 
 

Database programs are used to store information electronically.  Information about an 
individual object is entered into the fields on a record.  The records of all the objects in a 
group form the database. Information stored in the database can be manipulated to 
answer questions, presented as tables or reports, and analyzed using charts and graphs. 

 

RM Easiteach Database can be used for collecting, displaying, and analyzing any type of 
data.  There is support for dates, numbers, lists, and pictures, as well as sounds, 
animations, and videos.   

 

Data can be entered into fields in a wide variety of forms, sorted, and selected.  Charts 
and graphs are easy to produce and present, and tables can be displayed for quick 
viewing.  RM Easiteach Database also contains example databases for demonstrating and 
working with sample data in the classroom. 

 

Databases are powerful programs.  To make the best use of RM Easiteach Database, it is a 
good idea to read through the guide before you begin. 
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The Database Toolbar 
 

 

                                                 

Add Record 
Adds a new record to 
your database 

Delete Record 
Deletes a record 
from your database 

Next Record 
Opens the next record 
in your database 

Previous Record 
Opens the previous 
record in your 
database 

Add Field 
Adds a new field to a 
record 

Last Record 
Navigates to the last 
record in your 
database 

First Record 
Navigates to the first 
record in your database 

Properties 
Use to format fields, 
create check boxes and 
add drop-down lists 

                                 

Sort Up 
Sorts your database 
‘up’ by the selected 
field 

Chart 
Creates a range of charts 
to analyse your records 

Select Records 
Use to run a query to 
select records that match 
certain conditions 

Table Map 
Use to manage your records and 
create new reports 

Change Data 
View 
Displays your 
records in a table 

Sort Down 
Sorts your database 
‘down’ by the selected 
field 
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Reviewing the License Agreement 
 

If you wish to review your License Agreement while you are running RM Easiteach: 
1. Click File > About RM Easiteach. 

2. Select License Agreement. 

 

 

 

 

 

Using Database 
 

Starting Database 
 

To run Database, select Toolbars from the bottom of the RM Easiteach screen and click 
Database.  The Database toolbar is now visible on the RM Easiteach page. 

 

To see examples of RM Easiteach Database, select File > Open > Examples… and click 
Database.   
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Key Features 

 

Creating a Simple Database 
In the following example, Database is used to record the ages and heights of students in 
centimeters for a Science lesson.  It demonstrates what you can do with RM Easiteach 
Database. 
 

Making a Record  
A database is used to store information about a set of objects, such as a group of 
students.  The information about each object is kept on a record – for example, all the 
information kept on one student.  Each record is divided into fields, and each field contains 
a separate piece of information about the object. 

 

 
Creating Fields 

 
1. Select the Add Field button from the 

Database toolbar.  The new field 
displays as a blue dashed box. 

  

 

2. Click near the top of the page to 
place the field label and field box.  
The field label is highlighted in gray. 

 

 3. Type the word Name, and the field 
label changes from Field1 to Name.  
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4. Add two more fields further down the 
page and label them Age and Height. 

 
5. If you want to customize your field 

labels and boxes – for example, 
resize a field for a picture, add a fill 
color, or rotate a field label - see 
‘Editing and Formatting Fields’ on 
p. 34. 

 
 

 

 
The fields are now ready to accept your data. 

 

Entering Data 
You can enter text, numbers, and images into the field box. 

 

   

1. Enter your data by clicking inside a 
field box and typing the information. 
You have now created the first record 
in your database. 

 
2. You can preset the format of the data 

entered in any field box.  For example, 
you can choose to display the units of 
a measurement, such as cm, so that 
you need not type it each time.  See 
‘Editing and Formatting Fields’ on 
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p. 34 for simple instructions.   

 

3. If you want to add an image to a field, go to Resources and Multimedia Bank.  You 
can select images from Multimedia or navigate to other picture resources through this 
window.  Select the image and drag it into the field box. 

 

 

Adding New Records 
 

 

1. To make a record for the next 
student, click the New Record 
button.  You are presented with a 
blank record sheet to fill in. 

 
2. Repeat the procedure for everyone 

you wish to add to the database. 
 

 

 Your database now contains a record for each of your students. 
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Navigating Between Records 
 

 

 

 

 

 

 

Sorting Fields 
 

You can use the Sort Up and Sort Down buttons to sort the records in your 
database by any field. Text entries sort alphabetically; figures sort by number size.  
For example, if a Height field is sorted ‘up’, all the records in the database rearrange 
in order of height – shortest to tallest. 

 

Using Sort Up and Sort Down can help you spot trends or patterns in your database.          

 
   

You can quickly navigate through the database using the buttons on your Database 
toolbar. 

 
 

1. To move between adjacent records, use the Previous Record and Next Record 
buttons. 

 

2. To move to the beginning or end of your database, use the First Record and 
Last Record buttons. 

 

 

 

1. To select a field for sorting, you can either click inside a field box or select Change 
Data View and click a column heading.  

 
2. Now press the Sort Up or Sort Down button. The database sorts by the selected 

field. 
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Adding and Deleting Records and Fields 
 

 Deleting Records 
 

If you want to delete a record, navigate to the record and click the Delete Record button 
on the Database toolbar.  The record is deleted with no further warning message.   

 

This action cannot be undone on the RM Easiteach toolbar, so make sure that you are 
deleting the correct record.  

 

 

Adding and Deleting Fields 
 

You can add a new field or delete a field throughout your database. 

 

 

 

Adding a Field 
1. To add a field, open any record and select the New Field button.  
 
2. Place the field on your page and click on the field label to rename it. The field appears 

on all the records in your database. 
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Deleting a Field 

 

 

1. To delete a field, press the Table Map button on 
the Database toolbar to open the Table Map 
window.   

 
2. Select the field name for deletion, and click the 

Delete Field button on the Table Map window.  The 
field and its data are deleted from all records in your 
database. This action is carried out without further 
warning and cannot be undone.   

  

   

Displaying a Table 

 

 
You can view all the records you have created in your 
database in a table. 

 
1. Select Change Data View on the Database toolbar 

to display the table.  
 
2. You can edit the records in your database from this 

view by clicking on the data and amending it.   
 
3. To close the table, click Change Data View again. 
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You can also create reports - tables containing a selection of the fields in your database.  
For example, you can create a table showing only name and height.  Reports are 
particularly useful when a database contains a large number of fields.  Making a report 
produces a smaller table on the page, and allows the students to focus on a few fields.  

 

See ‘Table Map’ on p. 24 for instructions on creating reports. 

 

 

Editing Content 
 

You can change the information in records whether they are being viewed individually as 
pages or collectively as a table. 

 

 
 

 

 

 

 

1. Go to Toolbars > RM Easiteach at the bottom of the screen, and select Edit 
Mode from the RM Easiteach toolbar. 

 
2. To change the information on a page, simply click inside the required field box and 

amend its contents. 
 
3. To edit a number of records, select Change Data View to show the database in 

table format.  Click on the items to be changed.  The changes now appear on the 
individual pages. 
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Creating a Query 
 

A query lets you view data in your database that matches certain conditions – for 
example, all students in the database who are more than 136 cm tall. While the query 
is active you can only see the records that match these conditions.  

 

 
 

 

1. To run a query, click the Select Records 
button on the Database toolbar to open 
the Query window.   

 

 
 

 

 

2. Select the required field name from the 
drop-down list in the first box – in this 
example, the Height field. The next box 
becomes active. 
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3. Select the condition from the drop-down 
list in the criteria box – in this example, is 
greater than. You can choose to use 
mathematical symbols instead of words – 
such as > for is greater than - by clicking 
the Use symbols option.  

 
 

 

 

 

4. The third box is now active.  Select the 
required value from the drop-down list in 
the box.  The list contains all the values 
under the field name being queried. 
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5. When all the boxes are complete, press 
the Add to query button. The query 
appears in the large Query box.   

 
 

 

6. You can now choose to add another condition by selecting the And or Or buttons 
on the Query window. 

 
For example, And Age - is less than - 10. 

 

             
 
7. When your query is ready, click the Run Query button on the Query window.    
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8. While the query is running, you can only 
see the records that meet the conditions – 
the rest of the records are hidden from 
view.  The number of records found 
meeting the conditions is displayed on the 
page. 

 
9. To remove the query and return to normal 

viewing, click the Clear button on the 
Query window.   

 

 

 

 

Creating Charts 
 

Database lets you make bar charts, line charts, scatter graphs, and pie charts using the 
data in your databases. 

 

Selecting Fields 
 

To create a chart, you first need to select the fields to be used.  The first field name that 
you choose becomes the x-axis (horizontal axis) of the chart.  You can select the fields by 
clicking in the field boxes or selecting the field labels. 
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1. If you are working on a database that has been saved, go to Toolbars at the bottom 
of the screen and select RM Easiteach.  Now click Edit Mode on the RM Easiteach 
toolbar.  

 

2. Select a single field box by double-clicking 
inside the box.    

 
3. To select multiple field boxes, double-click 

inside the first box and then right-click 
inside subsequent boxes. 

   
 
 

 

4. You can also select fields by their field 
labels.  Double-click on one field label and 
then right-click on subsequent labels.  

  
 
 

 

 

5. You can also group-select several field 
labels by clicking the pointer close to the 
field labels and then holding and dragging 
across them. 

 
To look at the first chart, group-select all the 
fields – Name, Age and Height. 
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Choosing the Chart 
 

When the fields are selected, the Chart button is 
enabled on the Database toolbar.   

 

1. Click the Chart button to open the Chart palette. 

 
 

 

2. Selecting a chart type displays your fields in its format.  You can click between the 
types of chart to show your chart in different modes. 

 
3. If you want a background grid on your chart, select the Grid option.  Grids can be 

useful as a quick reference for calculating heights and values in a graph. 

 

 

4. You can rename your chart by 
clicking the title Chart and 
retyping the text.  
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Bar Chart  
 

Select the field labels and press the 
Bar Chart button to display them in 
bar chart format.  In the example, the 
Name field forms the x-axis because it 
was the first field selected.  

 

 

 

 

 
 

 

Sorting Fields 
 
Sorting a field before preparing a chart affects its appearance. Click in the field box, and use 
the Sort Up or Sort Down buttons on the Database toolbar. 
 
You can use the Sort Up button here to prepare a chart showing Height by Age, and the 
trend towards growth with age. 

 

 

 

1. Click in the Age field box and select Sort Up. The database records are arranged in 
order of age – youngest to oldest.  

 
2. Select the Name and then the Height field labels, and click the Bar Chart button from 

the Chart palette. 
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The chart now shows height by age, 
demonstrating the trend towards growth 
with age.   

 

However, the differences in height are 
difficult to read because the range of values 
on the y-axis (0-150 cm) is too great.  This 
can be improved by changing the values. 

 

Changing the Values 
 

You can change the values on the axes to alter the display and make the chart more 
readable and meaningful.   

 

 
 

1. Select the values on the chart and 
retype them – in the example the 
Height values are changed to start at 
130 and end at 145. 

 
2. Click the page to enter the new values. 
 
The chart now shows the differences in 
height, and a trend towards growth with 
age.  
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Line Charts 
 

Line charts are useful for showing trends set against each other.  They are prepared in 
exactly the same way as bar charts.  

 

In the example, the Sort Up button is used once again to prepare a line chart showing 
Height by Age, and the trend towards growth with age. 

 

 

 

1. Click in the Age field box, and use the 
Sort Up button on the Database 
toolbar.   
 

The database records are arranged in 
order of age – youngest to oldest.   

 
2. Select the Name, Age and Height 

fields and press the Line Chart 
button on the Chart palette. 
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Scatter Graphs 
 
Scatter graphs are used to show the relationships between different numeric series.  
A scatter graph must have at least two series of numbers.  In the example, height is 
plotted against age. 

 

 

 

1. Select Height and then Age from the field 
labels.  

 
2. Go to Chart and press the Scatter graph 

button to display your graph. 

 

3. You can change the start and end values 
on the axes to alter the display.  Simply 
select the values and retype them. 
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Charts Showing Frequency 
 

You can use Pie Charts and Bar Charts to show frequency – how often a type of data 
occurs in a field.  The frequency can be shown as a number or a percentage of 
occurrences. 

 

 

Pie Charts 
A pie chart shows how the total number of database entries in a field is divided up. The 
example shows the distribution of height in the database.  

 

 

 

1. To create a pie chart, select a single field 
label on your page and choose Pie Chart 
from the Chart palette.  The chart shows 
height by frequency of occurrence – the 
number of times each height occurs in the 
group. 

 
2. To select a single cell, simply double-click 

the cell. 
 
3. To show height by percentage of 

occurrence, select the Percentage option 
on the Chart palette. 
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Bar Charts  
 
Using bar charts you can express the frequency of individual numbers. 

 

 

1. Select a single field label – in the example, this is Height - and press the Bar Chart 
button on the Chart palette.   

     

              
 

     

 

2. As only one field label has been selected, the 
frequency option is selected by default.   

 
3. To show the frequency of occurrence as a 

percentage, select the Percentage option on 
the Chart palette. 
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Copying and Pasting Your Chart  
 

When you have completed your chart, you can copy and paste it to a new page.  

 

1. Select the chart and click the Copy button on the RM Easiteach toolbar.  

 

2. Now open the destination page.  To open a new page, select New Page at the side of 
the RM Easiteach screen.  Click the destination page and select Paste from the RM 
Easiteach toolbar. 

 

3. Once the chart has been copied and pasted, you cannot edit the text or values.  
However, you can change the chart format by selecting the buttons and options on the 
Chart palette. 
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Table Map 
 

 

 

 

 

 

 

 

Table Map is a powerful organizer.  You can 
create databases as tables; rename tables; 
sort, add, and delete fields; and make reports 
from your database records.   
 

Creating Databases in Table Map 
Using Table Map you can create a database that 
opens in table mode.  The column headings are 
the field names, and each row represents a 
record of the database.  This makes it easy to 
enter large amounts of data.   

 

Selecting Change Data View shows the 
individual records in the database. 

 

 

To create the database: 

 
1. Press Table Map on the Database toolbar 

to open the Table Map window. 
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2. Click the New Table button on the Table 
Map window.  The table header and first 
field appear on the Table Map window.   
 

If the New Table button is inactive, go to 
File > Save and save the file.  Reopen 
Table Map and select the New Table 
button. 

 

 

 

 

 

3. To add more fields, click a blank area on 
the column heading to select the table and 
activate the New Field button on the Table 
Map window. 

 

 

 

 

 

4. Click the New Field button to add more 
fields.  You can also add more fields by 
clicking a field tab and pressing Enter on 
your keyboard. 
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5. Click the Table1 heading and type the name 
of your database.  Then click inside the 
fields and change the field names as 
required. 

 

 
 
 

 

6. To place the table on the page, click the table header to select the table and then drag 
the table by the header onto the page. 

 

 

It is displayed as a blue dotted frame until it is released.  
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7. You can now close or minimize the Table Map window to view the table.  Click inside 
the first row to type the data for the first record.  Continue until all the records have 
been entered.  You can add a new record at any time by entering it into a new row on 
the table. 

 
 

       
 

 
 

 

To create a record form, rather than a table map, select Insert New Page from the side 
of the RM Easiteach screen and drag the individual fields onto the page. 
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Creating a Report 
 

You can create a report from your database – for example, a table showing only names 
and wings. This can be useful when your database contains a large number of fields.  
Making a report allows you to focus on a few fields in a table that fits on one page. 

 

When you create a report from your database, you must work on a new page in your RM 
Easibook.  If you amend the table shown in Change Data View on the original page, and 
the file is saved accidentally, the amendments to the table view will also be saved.  

 

 

1. Open a new page by selecting Insert New Page from the side of the RM Easiteach 
screen.  

 

 

 

 

2. Select Table Map on the Database toolbar to open 
the Table Map window.   

 
3. Click the tab of the first field that you want in your 

report.  Hold the Ctrl button down on your keyboard 
and select the other fields you require. 
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4. Click and hold one of the selected field tabs, and drag the fields onto the page.   
 
 

                
 
 

 

5. You can now close the Table Map window.   
 
The fields that are not being used in the 
report are simply hidden from view. They can 
be viewed at any time by selecting Change 
Data View on the Database toolbar. 

 

Your report is now complete. 
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Adding Fields 
 
1. To add a field and display the new version of the fields as a table, you must open a 

new page.  Click Insert New Page at the side of the screen.   
 

 

 

2. Click Table Map and select the field above 
the point where you want to insert a new 
field.  Click the Add field button on the 
Table Map window.  

 
You can also add a field by clicking the last 
field in the table and then pressing Return 
on your keyboard.   

 

3. Select the field name and change it. 

 

 
 

 

4. Click a blank area on the column heading to 
select the table, and drag it to the page.   
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5. You can move the new table view showing 
the new fields to page 1 of your RM 
Easibook.  Go to View at the side of the 
screen and select View > Storyboard.   

 

 
 

 

 

6. Click the table and drag it to the top left corner of the screen.  A red line displays the 
insertion point. 
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7. You can also delete unwanted tables in Storyboard.  Click the table to select it, and 
either drag it to the Garbage or press Delete on your keyboard. 

 
 

                              
 
 
8. To return to normal viewing, either select View > Normal or press page 1 at the side 

of the screen.  

 
 

 

 

Deleting Fields 

 
To delete a field, click the field and then the Delete field button on the Table Map 
window.  This action is carried out without further warning and cannot be undone.  
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Sorting the Database 
 
You can sort the database by clicking a field tab and selecting the Key button on the Table 
Map window. The field name highlights in blue and the records in the database sort ‘up’ by 
the field – text sorts in alphabetical order and numbers sort by number size. 

 

          

  

 

Relationship 
 

The Relationship button highlights when you 
have created a relationship between two tables – 
for example, when the field has a drop-down list.  
A line links the two related tables. 
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Editing and Formatting Fields 
 

Moving and Sizing Field Labels and Boxes 
 

 

1. Click near the field box or field label, or both items if required. Now hold down and 
drag the pointer over the objects to select them. 

 
2. To resize objects, click and drag the corner points.  If you want to rotate the field 

label, drag the green handle. 
 

 
 

 
 

3. To move a field box and/or field label, move the pointer over the selected objects until 
it changes to a hand, and then hold and drag them into place. 
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Formatting Fields 
 

You can preset the format of the data entered in any field box using the Effects button on 
the RM Easiteach toolbar. For example, you can choose to display height in cm or use 
currency symbols. 
 
1. Select the field that you want to format by double-clicking inside the field box or on 

the field label. 
 
2. Click Toolbars at the bottom of the RM Easiteach screen and select RM Easiteach.  If 

the Effects button is not visible, click the bottom arrow on the toolbar to extend it.  
 

 

 

 

3. Click Effects to open the Effects window 
and select Cell from the tabs. 

 
4. Select the format required from the list of 

Format options, and click the Effects 
button to format the field.  

 
5. The Format box contains commonly used 

formats.  If you want to create your own 
format, for example kg, simply type it in the 
format box. To make the format appear to 
the right of the value, enter a 1 before it, 
e.g. 1kg. 

 

 

 

6. The Cell tab also allows you to change the Justification (alignment) of the data in the 
field and set a Fill color for the fields. 
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Properties 
 

You can use Properties to check or change the type of data a field contains and how it is 
displayed.  You can also make an image the default image for empty cells.  Drop-down 
lists and Boolean (Yes/No or True/False) boxes are created using the Field Properties 
window. 

 

 
 

 

 

1. To open the Field Properties window, select the Properties button on the Database 
toolbar. 

 
2. To format a field, select the field name from the Field box and select the required 

Field type and properties.   
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Creating a Check Box 
 
You can format a field as a Yes/No check box.   
 
1. Create and name the field and open the 

Properties window.  Select the field 
name from the drop-down list. 

 

2. Go to Field type and select Boolean 
from the drop-down list. 

 

   

 
  

 

 

 

3. The field changes to a box.  The box can 
be ‘checked’ or cleared by clicking on it.  
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Inserting a Default Image 
 

You can use the Picture box to select an image to appear on all empty fields in the 
records.  For example, you could choose a school emblem, such as a bee.  Placing a 
picture in empty fields helps to highlight fields that have not been filled in. 

 

 

 

1. Click the Picture button under the Picture box. The 
Multimedia Bank opens. You can choose an RM 
Easiteach picture file or navigate to other picture or 
photo files. Click the required image and it appears in 
the Picture box.  

 
2. If the image has not already appeared in the empty 

fields, click the Next Record button on the Database 
toolbar to activate it.  

 
 
 
 
 

 

 

 

Creating a Drop-Down List 
 
If you have a field that contains a limited number of entry types – for example, a gender 
field – you can create a drop-down list to make entering easier. 
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1. After you have created and named your field, 
open Properties on the Database toolbar. 
Click the arrow in the Field box on the 
Properties window, and select the field. 

 
2. Now select the Use list option in List values.   
 
3. Type a word into the small List values box and 

click the Add button.  The word appears in 
the large List values box. You can also add 
pictures from the Multimedia Bank by 
selecting Picture…. 
 

 

 

 

4. When your list is complete, close the Field Properties window. Clicking inside the field 
box now reveals a drop-down list.  Click an item to enter it. 

 
 

                                     
 

If you want to make the list appear in a particular order, for example months of the year, 
you need to enter them in reverse order. 
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Locking Databases 
 

You may wish to lock your database to prevent the field labels and boxes being deleted or 
changed in error.  This will not, however, lock the data within the fields. 

 

 

 
 
 

 

 

 
 

 

1. Open the Easiteach toolbar and click the down arrow at the bottom of the 
toolbar to display the Utilities button.  

 
2. If you are working on a saved database, press the Edit Mode button. 
 
3. Select all the field labels and boxes by clicking in the top left corner of the page and 

dragging to the bottom right.  They can also be selected by pressing Ctrl+A on the 
keyboard.   

 
4. Click the Utilities button to open the Utilities toolbar and press Lock/Unlock to 

Background.  Your selection is now locked to the page. 
 
5. To access locked field labels and boxes, click the Access Locked Items button on 

the Utilities toolbar.  The button highlights while the locked items are accessible.  
You can now edit the fields.   

 
6. Click the Access Locked Items again to relock or click the Lock/Unlock to 

Background button to remove the locking completely. 
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Printing Database Files 
 

To print a Database page, select File > Print.  Choose the number of copies required and 
check that the Only this page option is active. 

 

 

Tips for Using Database 
 

Quick Tips  
 

• To enter today’s date in a field or anywhere on the page, click where the date is 
required and press Ctrl+D on your keyboard.  To change the format of the date, see 
‘Editing and Formatting Fields’ on p. 34. 

 

• When viewing your database in table format, you can alter the width of the columns to 
make viewing easier. Hold the pointer over the edges of the columns until the arrows 
appear. Now hold down and drag the column to a more suitable width.  

 

Ideas for Lessons 
 

• If the students need to collect data, you can create the field boxes and field labels for a 
database table and print it blank for students to use.  
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• You can either use the individual 
sheets or select Change Data 
View for a table format. 

 

   

• If you wish to use sample data, rather than creating your own, you can use pre-
prepared examples of Database. Go to File > Open > Examples... and select 
Database. 

 

• You can use these files as demonstration models.  

 

• Ask the students to create a database entry screen that can also be used as a 
questionnaire. 

 

• Take photos of the students with a digital camera or scan in images of their pets, and 
add these to your student database. 

 

• Encourage historical research by creating databases about interesting personalities from 
the past. 
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• Chart the growing patterns of plants in different habitats and use the scatter graph 
function to plot relationships.   
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